Instalación de Subclipse en Debian (y derivados)


 


Enlace al video

Si estás interesado en instalar Subclipse como cliente SVN para Eclipse, puedes seguir de forma general los pasos explicados a continuación, los cuales son independiente del sistema operativo y serán válidos para Windows, Mac o Linux, salvo el procedimiento de cómo instalar y configurar la librería JavaHL en Debian (y derivados como Ubuntu).

Instalación de Subclipse:

De forma general, estos son los pasos para instalar Subclipse en Eclipse:

  1. Abrir Eclipse, e ir a Help > Install New Software.
  2. Agregar el url de Subclipse para la versión de Eclipse que se tenga. Por ejemplo, para Galileo se debe agregar http://subclipse.tigris.org/update_1.6.x
  3. Seleccionar todos los componentes mostrados: Core SVNkit Library, Optional JNA Library (recommended) y Subclipse.
  4. Aceptar el acuerdo de licencia para iniciar la instalación. Casi finalizando la instalación nos aparecerá un mensaje advirtiendo que se instalará software no firmado, aquí aceptamos.
  5. Al finalizar nos pedirá reiniciar Eclipse.

Librería JavaHL en Debian

Sino quieres usar la librería SVNKit sino JavaHL entonces debes instalar el siguiente paquete:

 aptitude install libsvn-java

Luego se tienen dos alternativas para indicarle a Eclipse la existencia de dicha librería:

  1. Lo correcto es tratar de hacer que Eclipse lea el archivo de configuración con la ruta a la librería JavaHL. Yo la verdad no he logrado dar con el archivo eclipse.ini para el usuario, solo el archivo general /etc/eclipse.ini. Allí como root se puede puede agregar la línea mostrada en negritas, quedando algo como esto:
  2. -startup
    plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
    --launcher.library
    plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0.200.v20090520
    -showsplash
    org.eclipse.platform
    --launcher.XXMaxPermSize
    256m
    -vmargs
    -Djava.library.path=/usr/lib/jni
    -Xms128m
    -Xmx512m
  3. La otra solución es hacer un enlace simbólico a la librería, esto es:
  4. ln -s /usr/lib/jni/libsvnjavahl-1.so /usr/lib/
  5. Reiniciar Eclipse y verificar yendo a Preferences > Team > SVN, donde debe aparecer la versión de la librería.

Librería SVNKit

Con la instalación al principio se descargó la librería SVNKit, la cual puede usarse en sustitución de JavaHL, sin necesidad de configurar ningún archivo adicional de inicialización y con la ventaja de ser multiplataforma, es decir, que en Windows y Mac también servirá. Para esto solo hay que ir a Window> Preferences > Team > SVN y seleccionar en la interfaz SVN a usar la opción que diga SVNKit:

SVNKit

Ya con esto podrás usar este cliente SVN en Eclipse!!


, ,

  1. #1 by Luis Gallardo on 30/10/2011 - 6:28

    @AUGUSTO no uso Canaima, pero en Debian y en Ubuntu esa impresora se reconoce a la primera. Ahora el escáner lo puedes configurar como se explica aquí. Saludos!

  2. #2 by AUGUSTO on 30/10/2011 - 12:48

    Gracias por su ayuda profesor ya resolvi…En estos casos se ejecuta los siguientes comandos:
    sudo apt-get install os-prober y luego
    sudo update-burg y se resuelve.
    queria preguntarle como se pueden instalar las impresoras epson en canaima sera que usted sabe?? por que tengo mil problemas con la epson tx110

  3. #3 by Luis Gallardo on 17/10/2011 - 1:23

    @AUGUSTO lo que comentas es que GRUB no te detecta el sistema operativo alterno. Creo que Canaima utiliza GRUB 2, por lo que debes investigar cómo agregar otros sistemas operativos con esa versión. Saludos!

  4. #4 by AUGUSTO on 17/10/2011 - 8:25

    mil gracias profesor de verdad es de gran ayuda… quería preguntarle otra cosa, siempre q instalo dualidad (linux–windows) en un pc, primero instalo el linux y luego el windows porque de lo contrario no me deja seleccionar el so con el cual quiero trabajar, pero esta vez instale xp y luego canaima e inicia canaima directo. sabe usted como solucionar este problema??

  5. #5 by Luis Gallardo on 16/10/2011 - 1:12

    @AUGUSTO puedes usar Eclipse en Ubuntu. Basta con que instales las herramientas de desarrollo para Java:

    aptitude install eclipse-jdt

    Esto automáticamente instalará algún entorno de desarrollo para Java.

    Saludos!

  6. #6 by AUGUSTO on 15/10/2011 - 2:23

    Buen dia profesor le escribo para preguntarle cual es la forma mas facil y efectiva de programar java en ubuntu? que pauete debo instalar? que procedemiento debo hacer, yo ya se un poco de java pero en windows usaba eclipse y jdk6 pero no se que debo hacer para programar de igual forma en ubuntu… :(

Los Comentarios están cerrados