Setting ViewSonic G800 on Debian 6.0


ViewSonic G800

Some coworkers decided to install Debian on a PC with a ViewSonic G800 monitor and a ATI Technologies Inc Rage XL graphic card, but the best resolution they could get was 800×600. After checking out the X serverr’s drivers, which were installed correctly for the ATI card, and try some drivers variants (r128, radeon,k etc), I asked the monitor’s settings to the person who installed the system, and he said he didn’t know them or the manual’s whereabouts. By searching on the net I came across with the manual in the manufacturer’s web page, of particular interest is the table with the refresh parameters:

G800 1024x768

With this information I proceeded to created the X server configuration file, I mean, the  /etc/X11/xorg.conffile:

Section "Device"
 Identifier "Configured Video Device"
 Driver "ati"
EndSection

Section "Monitor"
 Identifier "Configured Monitor"
 HorizSync 60.02
 VertRefresh 75
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
EndSection

The monitor’s manual can be downloaded on the manufacturer’s web page, but you must enter the monitor code. If you don’t have it, here you have the  manual in PDF.

Reference: man ati

  1. #1 by Luis Gallardo on 17/03/2012 - 9:10 am

    @Alfredo cómo estás? Tienes que revisar si la tarjeta gráfica está soportada en la versión de Backtrack que estás usando, y si no lo está tratar de compilar el driver por tu cuenta. Según el enlace que pasaste, es una tarjeta Intel HD Graphics 3000, pero un lspci -v no está de más para corroborarlo. Saludos!

  2. #2 by Alfredo Cedeno on 17/03/2012 - 8:49 am

    Epa Luis Como has estado? Te contacto por el siguiente motivo: La empresa me ha asignado una ASUS Serie X53E http://www.notebookcheck.net/Review-Asus-X53E-SX082V-Notebook.57227.0.html

    Le instale Backtrack 5r2 y hasta ahora funciona bien, aunque cuando voy a System > Preferences > Monitors, no reconoce el monitor. Y cuando lo conecto a un monitor externo pasa lo mismo.

    Aun asi me muestra display y puedo trabajar, pero sin la posibilidad de utilizar dual monitor.

    Alguna idea en como resolver esto.

    Gracias.

  3. #3 by Luis Gallardo on 18/12/2011 - 8:40 am

    @Dark_Sasuke una de las primeras cosas que se tiene que revisar es si el monitor es reconocido por las herramientas de configuración gráfica, sino es así toca crear el archivo xorg.conf con los parámetros específicos de monitor.

    Como bien dices, esto sirve para configurar otros monitores, incluso más modernos.

    Saludos!

  4. #4 by dark_sasuke on 17/12/2011 - 9:01 pm

    Esto ademas sirve como un buen ejemplo para configurar otros monitores, es algo que algunas veces estuve buscando y jamas encontraba!

(will not be published)